Checkout Editor is Limited
Resolved
Jan 09 at 01:02am IST
The issue caused by a recent Shopify change affecting Checkout UI Extension components has been resolved. The affected elements are now rendering correctly, and unintended content (including raw JSON) is no longer displayed.
All checkout extension components have been safely restored across stores. No action is required on your end.
We’ll continue to monitor the situation closely and will share updates if anything changes. Thank you for your patience.
Affected services
Updated
Jan 09 at 12:46am IST
We’ve resolved the issue impacting live experiences.
Widgets are now rendering correctly and displaying as expected. If you previously paused an experience or removed mount points, it’s now safe to resume or restore them.
As a result, all currently live experiences should be functioning as expected, and the live issue is considered resolved.
Current limitation
At this time, editing existing checkout experiences or creating new checkout experiences may not work as expected. We’re actively working on this and will share another update as soon as this is addressed.
Thanks for your patience, and please let us know if you notice anything unexpected on live traffic.
Affected services
Created
Jan 09 at 12:19am IST
We’re currently investigating an issue caused by a recent Shopify change that appears to have broken backward compatibility in certain Checkout UI Extension components. As a result, some elements that were expected to be hidden are now being rendered (including raw JSON content).
As a precaution, we’ve temporarily removed all checkout extension components across all stores. No manual action is required on your end, and there’s no need to pause experiences individually.
We’re actively working on a fix and will share an update shortly.
Affected services